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Java Testing with JUnit 5 Introduction

Course Overview

+ This is a 2-day course about testing in Java, using JUnit 5

# |t covers the following high-level areas:
— Writing and running tests
— Using-mock objects
= Testing enterprise components

o A few notes [see.notes]...<—— |hey, that's funny

— The course does not require prior experience with unit testing or
JUnit, and all'the fundamentals.of JUnit 5 are covered in detail

— JUnit 5 requires-a-Java 8 runtime and employs several of its
new language features and APls

Introduction 2

Notes:

+ Note that the structure and implementation of JUnit 5 is_substantively different than JUnit 4, though
the core testing principles and techniques are the same:

— If you have experience with previous versions of JUnit,(that will certainly be-helpful, but you'll
need to be aware of the differences.

* As one example, JUnit 5 has a @Test annotation, as does JUnit 4, but these are different
annotations — they are in different packages and have different attributes:

+ Java 8 was released in 2014. At a minimum, you're mostly likely aware that this is a significant
release, bringing with it new language features and APlIs, including:

— Lambda expressions and the formal definition of a functional interface.
— The ability to provide implemented methods in interfaces.

— Streams API (java.util.stream), Date/Time API (java.time), Optional (java.util), and a
family of predefined functional interfaces (java.util.function):

Predicate, Function, Consumer, and Supplier.
+ It's undoubtedly the most significant release since Java 5.
— If you've managed to steer clear of it so far, it's time to get acquainted!

— The course includes a Java 8 primer, which should be enough to get you started. For more
complete coverage, consider the 2-day Java 8 New Features course.

Copyright © LearningPatterns Inc. All rights reserved. 2



Java Testing with JUnit 5

# Session 1: Unit Testing with JUnit 5
¢ Session 2: Writing and Running Tests
& Session3: Testing with Mocks

o Session 4:Testing Enterprise Components

Introduction

Course Agenda

Introduction 3

Notes:

Copyright © LearningPatterns Inc. All rights reserved.



Java Testing with JUnit 5 Introduction

Typographic Conventions

+ Code in the text uses a fixed-width font
Catalog catalog = new CatalogImpl()
+ Code fragments are the same, e.g., catalog.findById(4)
¢ We bold/color text for emphasis
¢ New terms are often introduced in bold italics
~Filenames-and paths are also in italics, e.g., Catalog.java
+ Notes are indicated with a superscript number () or a star *
¢ Longer code examples appear in a separate code box (below)

package com.javatunes.catalog;

public class CatalogImpl implements Catalog {
public MusicItem findById(long id) {

}
}

Introduction 4

Notes:

(™ If we had additional information about a particular item'in the slide, it would appear here in the
notes, with the appropriate superscript.

+ We might also include related information that pertains more generally to the'slide.

Copyright © LearningPatterns Inc. All rights reserved. 4



Java Testing with JUnit 5 Introduction

¢ The course has numerous hands-on lab exercises
— Many use types from a fictional case study called JavaTunes
 /An online music store
— The lab instructions are separate from the main manual

o Setup files are provided with skeleton code for the labs
—-Students.add code focused on the topic at hand

— There.is a solution zip with completed lab code

+ Lab slides have an-icon in the upper right corner of the slide

— The end of alab is marked with.a stop sign

Introduction 5

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 5
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Overview
Tests and Assertions
! Test Fixtures and Lifecycle

Session 1: Unit Testing with JUnit 5 6

Notes:
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Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Session Objectives

+ Understand basic principles of unit testing

¢ Understand JUnit library structure and testing model
# Set up the IDE and organize tests in an IDE project
+ Write and run tests'in the IDE

+ Write assertions toverify correct application behavior
+ Use test fixtures'to manage the objects under test

+ Understand the lifecycle of a'test run

Session 1: Unit Testing with JUnit 5 7

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 7
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Session 1: Unit Testing with JUnit 5 8

Notes:
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Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Unit Testing Overview

# Testing is a critical part of software development
— Assess behavior of software with respect to expectations

+ Unit testing focuses on "individual units" of a larger system
— In Java, this is typically a method of a class
— Test cases are test methods written to perform each unit test
» Shows that the code does what we (developers) expect it to do
— Verifies that individual parts of a system are correct
+ And-that they remain correct when changes are made (this is key)

+ Unit testing allows you to write better code in less time
— Quickly detect bugs when changes / additions are made
— Verification of edge cases that might otherwise be overlooked
— Encourages writing smaller chunks of testable code (also key)

Session 1: Unit Testing with JUnit 5 9

Notes:

+ Unit testing is generally done by the developers themselves.

+ The testing we are talking about does not measure "quality*-but-rather how closely software meets
requirements.

— All requirements are captured in tests. When the code passes‘thetests, you are"finished"
writing the code ("finished" in quotes because all code is subject torefactoring at some paint).

— The codebase of tests is like an "executable specification" of the system.

— As requirements evolve and/or the software increases in complexity and‘size, testing becomes
even more important.

— Note that unit testing doesn't measure whether the code performs what the end-user wants. It
checks that the code does what the developer expects.

+ |deally, unit testing is done in isolation from other parts of the system — with each test case being
independent from the others.

— Sometimes mock or fake objects are used to help perform a test case in isolation.

Copyright © LearningPatterns Inc. All rights reserved. 9



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

JUnit Overview

+ Open-source Java testing framework
— Most popular in industry — universally supported in IDEs, tools
— See notes for a brief history

o Automates unit testing of Java code
+ Provides standard way to write and organize tests

+ Consists of classes'and annotations to write and run tests
— Annotations for declaring test methods (@Test)
— Assertions fortesting actual results against expected results
— Test fixtures forisetting up each test's environment
— Test engines and runners
* Built-in, plus extension-mechanism for:3rd party implementations

Session 1: Unit Testing with JUnit 5 10

Notes:
+ JUnit Home: http://junit.org.

o A brief history:

Kent Beck developed the SUnit automated test tool for Smalltalk in the mid-1990s.

Beck and Erich Gamma (of design patterns Gang of Four) supposedly developed JUnit on a
flight from Zurich to Washington, DC.

* Probably true, as Beck's main JUnit example uses a Money class;’and many instances of
Money in his example have currency CHF (Swiss Franc).

Martin Fowler has said, "Never in the field of software development was so'much owed by'so
many to so few lines of code."

Many "xUnit" tools have since been developed for other languages and environments, including
Perl, C++, Python, Scala, Visual Basic, C#, .NET, web testing (HttpUnit), database testing
(dbUnit), etc.

+ JUnit is the #1 most prevalent 3rd party library used in Java projects.
+ JUnit is simple, effective, ubiquitous.

Copyright © LearningPatterns Inc. All rights reserved. 10



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Introducing JUnit 5

+ History and evolution
— JUnit 3: one JAR junit.jar

» Subclass TestCase, write test methods named "testSomething",
optionally override designated lifecycle methods for init and cleanup

— JUnit 4:.iwo JARs junit.jar, hamcrest. jar
« Annotation-based approach: @Test, @Before, @GRunWi th, etc.

« Enhanced test run lifecycle, "matcher" assertions, cleaner testing for
exceptions, parameterized tests, timeouts, external test runners

o JUnit 5 injtial release September, 2017
— Structure is significantly more complex
» Multiple components: platform +test engine + API (details next)
— BUT from a developer perspective, it's fundamentally the same
— Java 8 runtime required (older-compiled code ok)
— Java 9 ready (where code (in JARS) is organized into modules)

Session 1: Unit Testing with JUnit 5 11

Notes:
+ Note that the Java package names have changed with each release:
— JUnit 3: junit.framework, junit.runner, junit.extensions.
— JUnit 4: org. junit and several subpackages.

— JUnit 5: org.junit.platform, org.junit.jupiter, org.junit.vintage
(each with several subpackages).

+ As mentioned in the Introduction session, JUnit 5 requires a Java 8 runtime and employs several of
its new language features and APls.

— But using it to test older code (Java 7 and earlier) is just fine.

Copyright © LearningPatterns Inc. All rights reserved. 11



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

¢ Console Launcher
— Flexible test run environment from the command line

¢ Java 8 lambdas
o Test runfiltering and conditional test execution

+ Display names and nested tests
— Aids. in test. reporting and organizing tests

¢ Parameterized tests

# Single standardized extension.mechanism

— Additional lifecycle callbacks, more flexible approach for 3rd
party libraries, e.g.; Spring, Mockito

Session 1: Unit Testing with JUnit 5 12

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 12



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

JUnit Library Components

¢ JUnit 5 = JUnit Platform + JUnit Jupiter + JUnit Vintage

+ Platform provides API and infrastructure for TestEngines,
legacy.test runners, and build tools (Gradle, Maven)

— Also provides a Console Launcher for command line use

+ Jupiter is the programming model and API for test developers
— This is your main interface to JUnit
» As a developer writing unit tests, this is what you code to
— Also provides a TestEngine to run JUnit 5 tests on the Platform

+ Vintage allows JUnit 3 and 4 tests to run on the Platform
— Via another TestEngine
— In fact, that's all Vintage'is — a TestEngine for older tests

Session 1: Unit Testing with JUnit 5 13

Notes:

¢ Compared to JUnit 3 (one JAR) and JUnit 4 (two JARS), it can be difficult to figure out exactly which
pieces do what, and which pieces you need in your project. We clarify all that here.

+ From the JUnit User Guide (paraphrased, text added, and reorganized):
— The JUnit Platform serves as a foundation for launching testing frameworks on the JVM:

It defines the TestEngine API for developing a testing framework that.runs on the platform.
JUnit Jupiter and JUnit Vintage both supply TestEngine implementations ~ for running JUnit5
("Jupiter") tests, and JUnit 3 and 4 ("Vintage") tests, respectively.

It provides a ConsolelLauncher to launch the platform from the command line.
» It provides plugins for running tests in Gradle and Maven build systems.

It also provides a JUnit 4 Runner class for running JUnit 5 Jupiter tests in IDEs and-build systems
that support JUnit 4 but do not yet support the JUnit 5 Platform directly.

— JUnit Jupiter is the combination of the new programming model and extension model (APIs) for writing
tests and extensions in JUnit 5. It also provides a TestEngine (JupiterTestEngine) for running
Jupiter-based (JUnit 5) tests on the platform.

— JUnit Vintage provides a TestEngine (VintageTestEngine) for running JUnit 3 and JUnit 4 tests on
the platform.

+ As mentioned in the description above, "Jupiter test" = "JUnit 5 test" — these are synonyms.
— The User Guide generally uses the term "Jupiter test."

Copyright © LearningPatterns Inc. All rights reserved. 13



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

JUnit Library Components - Illustrated

+ You, the developer, are the stick figure coding to the JUnit API

O
f') < i
4

junit.jar hamcrest.jar

junit-jupiter-api

JUnit Jupiter JUnit Vintage
junit-jupiter-engine junit-vintage-engine
JupiterTestEngine VintageTestEngine
IDEs Maven
command prompt 2 Gradle . .
programmatic launch maven-surefire-plugin

v L |

Console Launcher junit-platform- junit-platform-
junit-platform-console gradle-plugin surefire-provider

JUnit Platform
TestEngine APl " junit-platform-engine

junit-platform-launcher

Session 1: Unit Testing with JUnit 5 14

Notes:
+ INDEED, a bit more involved than putting one or two JARs on the classpath!

+ JUnit provides two TestEngine implementations out of the-box:

— JupiterTestEngine runs "Jupiter" tests, aka "JUnit 5" tests.on the JUnit Platform.
Located in the junit-jupiter-engine module.

— VintageTestEngine works with JUnit 4 to run "Vintage" tests (JUnit-3 and 4 tests) on the JUnit
Platform.
Located in the junit-vintage-engine module.

+ The slide does not show every single piece. Internal and less-often-used modules have been
omitted. Included in this listis junit-platform-runner, which allows older IDEs and tools that
support JUnit 4 but do not yet support the JUnit 5 Platform directly, to work with the Platform.

Copyright © LearningPatterns Inc. All rights reserved. 14



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Writing a Test — First Example

+ Create a test class, write a test method annotated with @Test
— Set up a business object and invoke business method(s) on it

— Make assertions about the results via static methods in the
Assert-ions class

— Main JUnit 5 base package is org. junit. jupiter.api

package demo.junit;

import static org.junit.jupiter.api.Assertions.*; // see notes
import org.junit.jupiter.api.Test;

class StringTest { // test class, test methods need not be public

@Test
void testLength(). {
String msg = "hello"; // object under test
assertEquals(5, msg.length()); < // expected, actual
assertTrue(5 == msg.length()); // alternative assertion
3
}
Session 1: Unit Testing with JUnit 5 15
Notes:

¢ DISCLAIMER: this is obviously a demo example — you would never write tests to verify that Java
strings work correctly(!)

o We'll discuss assertions in more detail later, but for now:
— assertEquals(expected, actual) passes when expectedequals" actual.

* For primitive types, this means value equality (==), for class types, this means
equals(). More on assertions later.

— assertTrue(condition) passes when the supplied condition is true.

+ Note on static imports: they can certainly make your code more readable, but are best used
sparingly, and only when importing the static members of one (maybe two) classes. Otherwise,
readers of your code (including you a few months later) won't know which class a static member
comes from, and the code is now less clear.

— Having said that, with regard to JUnit tests, you will almost always see (and use) the static
import above. You have our blessing.

+ JUnit 4 users: this is a different package and different @Test annotation than those in JUnit 4!

Copyright © LearningPatterns Inc. All rights reserved. 15



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Running Tests in the IDE

+ All modern IDEs provide a graphical test runner
— Usually provide a progress bar: green = pass, red = fall
— "If the bar is green, the code is clean”

Runs: 1/1 B Errors: 0 B Faiures: 0
| > 7 |

E---E_T_:l demo.junit.stringTest [Runner: JuUnit 4] (0.000 s)
‘g testLength (04000 s)

¢ Failedtests offer "advice" as to why it failed, and where

Runs: 1/1 BeErrors: 0 B Failures: /1

E---E_?_;I demo.junit.StringTest) Funner: JUnit 4] (0.005 <)
[ =k testl ength (0.005 s)

= Failure Trace o=

[0 java.lang.AssertionError: expected:=4= but was:<5> )

= at demo.junit.StringTest.testLength(StringTest.java: 11}

Session 1: Unit Testing with JUnit 5 16

Notes:

+ The failed test above was deliberately triggered with-an.incorrect assertion.

+ The screenshot of the failing test was taken with JUnit 4, very similar in dUnit 5.

Copyright © LearningPatterns Inc. All rights reserved. 16



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Running Tests in Other Environments

o Ant <junitlaunchers> task in build.xml (")
> ant run-tests

¢ Maven-test phase
> mvh_test

+ Standalone (command line)
—JUnit Platform Console Launcher — single JAR with a main-class

¢ Programmatically
—Write your own code to the Launcher API

o We'll discuss these other test run environments later (2)

Session 1: Unit Testing with JUnit 5 17

Notes:

(M This new Ant task is the JUnit 5 counterpart to the older. <junit> task for JUnit 3 and 4 tests.

— As of this writing, it is nearing completion and appears to be scheduled forinclusion in a later
Ant 1.10.x release. See http.//www.mail-archive.com/dev@ant.apache.org/msg46672.html.

— Although Ant has fallen out of favor, with preference to more modern build systems such as
Maven and Gradle, there are still shops using it — and this new./<junitTlauncher> task will be
useful for them.

@ For most of the course, we'll run tests in the IDE. It's easy, fast, and flexible.

— As you write your business code, you should be writing and running tests for that code (at least
a subset of them) all the time — if you haven't seen a green bar in more than'5 minutes, you're
doing it wrong!

— In a later session, we'll work with a Maven project, use the Console Launcher, and look at code
written to the Launcher API.

Copyright © LearningPatterns Inc. All rights reserved. 17



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5

Naming Conventions and Organizing Tests

¢ MyClass is tested by MyClassTest

why would
¢ MyClassTest is in same package as MyClass this matter?

=2 src

¢ Parallel src and test directories | 5@ commath

. P [4] Calculator.java
— Both branches are checked into source control |= @ test

. ©-H com.math

—"Package / deploy only the src classes [0 CakulatorTest.java
— Alternatively, two IDE projects — test code in separate project

+ For test methods:
- myMethod () is tested by testMyMethod ()
— Must be annotated by @Test to be run as a test case

* Method name technically doesn't matter, but this historical naming
convention is still used — see notes

* We'll use this convention,in the labs, along with others

Session 1: Unit Testing with JUnit 5 18

Notes:

+ This naming convention for test classes has been around since the beginning, and is still by far
the most widely used.

— Other notations include MyClassTests (plural) and TestMyClass.

— NOTE: JUnit 5 uses a new discovery mechanism to find test classes, and its default matching
pattern finds test classes ending with "Test" or "Tests" — so you are strongly encouraged to use
this naming convention (and not TestMyClass).

+ The naming convention for test methods is historical, but still used...though fading over time.

— In JUnit 3, test runners followed an ad hoc contract, in which all public methods in the test class
named "testSomething" were run as test cases.

» This was a requirement. If your test method didn't begin with "test", it didn't get run.

— That was two major releases (and many years) ago. Starting with JUnit 4, the @Test annotation
designates test methods — the name of the method is immaterial to the JUnit test runner.

» Current thinking is that the name of a test method should capture the intent and expected
outcome of the test — and long method names are fine for test methods. We will employ
this idea in some of the labs.

* As one example, some developers use "should" as a test method prefix, e.g.,
shouldThrowExceptionWhenSomeCondition(), shouldBeEmptyCollection(), etc.

Copyright © LearningPatterns Inc. All rights reserved. 18



Java Testing with JUnit 5 Session 1: Unit Testing with JUnit 5
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Lab 1.1 - Getting Started with JUnit

Session 1: Unit Testing with JUnit 5 19

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 19
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Labs: Java Testing with JUnit 5 Introduction

Release Level %

+ This manual contains instructions for creating and running the labs
using the following software packages:

— Java 8 SDK

— Eclipse Java EE Edition — Oxygen/4.7.2 or later
* JUnit 5 support was added in 4.7.1a

¢ Instructions‘are geared towards Windows-based operating systems
— You'should easily be able to adapt to other environments, e.g., Mac OS

Introduction 2

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 2



Labs: Java Testing with JUnit 5 Lab 1.1 — Getting Started with JUnit
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Lab 1.1 - Getting Started with JUnit

Lab 1.1 — Getting Started with JUnit 3

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 3



Labs: Java Testing with JUnit 5 Lab 1.1 — Getting Started with JUnit

Lab Synopsis w

¢ Overview:
— Set up our lab environment and the Eclipse IDE
— Set up an IDE project to use JUnit

— Test a.simple Calculator class using some basic assertions
« We'll discuss assertions in detail after the lab

+ Builds on/previous labs: none

¢ Approximate time: 1525 minutes

Lab 1.1 — Getting Started with JUnit 4

Notes:

Copyright © LearningPatterns Inc. All rights reserved. 4



Labs: Java Testing with JUnit 5 Lab 1.1 — Getting Started with JUnit

Information Content and Task Content w

+ Informational content is presented in the normal way — the same
as in the student manual

— Like these bullets at the top of the page
o Tasks you need to do are in a "Tasks to Perform" box

Tasks to Perform

¢ Look at these.instructions, and notice the different look of the box
— Make a note of how it looks, as future labs will use this format

+ Make sure that you.have Java 8 or later installed
— Likely in a directory such.as C:\Program Files\Java\jdk1.8.0_xxx
— If not, you'll need to install it — it can be downloaded from:
http://oracle.com/technetwork/java/javase/downloads

Lab 1.1 — Getting Started with JUnit 5

Notes:

+ The setup files may be on your workstation, or they may be provided by your instructor.

Copyright © LearningPatterns Inc. All rights reserved. 5



Labs: Java Testing with JUnit 5 Lab 1.1 — Getting Started with JUnit

Extract the Lab Setup Zip File %

+ To set up the labs, you'll need the course setup zip file
— Ithas a name like: LabSetup_JavaTesting _yyyyMMdd.zip

+ Ourbaseworking directory for this course will be
C:\StudentWork\JavaTesting

— Gets created when we extract the lab setup zip
= Ancludes a directory structure and files needed in the labs
— Allinstructions assume that this zip file is extracted to C:\
If youchoose a different directory, please adjust accordingly

Tasks to Perform

+ Unzip the lab setup file to C:\

— Creates the StudentWork/JavaTesting directory structure,
containing files that you will need for doing the labs

Lab 1.1 — Getting Started with JUnit 6

Notes:

+ The setup files may be on your workstation, or they may be provided by your instructor.
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The Eclipse Platform %

+ Eclipse (www.eclipse.org) is an open source platform for building
integrated development environments (IDEs)

— Used mainly for Java development — can be extended via plugins and
used in other areas (e.g., C# programming)

¢ Originally developed by IBM
~ Released into open source
— IBM's RAD productline is built on top of Eclipse

o Eclipse products have two fundamental layers:

— Workspace: files, packages, projects, resource connections,
configuration properties - all stored on the filesystem

— Workbench: editors, views, and perspectives — the Ul you work with

+ We will set up the workspace and workbench, then do our lab

Lab 1.1 — Getting Started with JUnit 7

Notes:

+ The workbench sits on top of the workspace and provides visual artifacts (the Ul) that allow you to
access and manipulate the underlying workspace resources.
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Getting Started with Eclipse %

Tasks to Perform |

+ Make sure you have Eclipse installed — likely in C:\eclipse i
— If not, you'll need to install it — see instructions in notes i

+ Launch Eclipse: go to C:\eclipse and run eclipse.exe :

— A dialog-box should appear prompting for a workspace location ()
— Set workspace location to C:\StudentWork\JavaTesting\workspace ()
—~ If a different default workspace location is shown, change it

CP Edlipse Launcher il

Select a directory as workspace

Eclipse uses the workspace directory to store its preferences and development artifacts.

Y
c

J ~|  Browse... |

(ﬂorkspace: | C:\StudentWork\JavaTesting\workspac

[~ Use this as the default and do not ask again
» Recent Workspaces

Cancel

Lab 1.1 — Getting Started with JUnit 8

Notes:

() If the workspace dialog box does not appear, that means that Eclipse was previously launched on
your system, a workspace directory was chosen, and the “Use this as the default" box was
checked.

— In this case, you should change workspace to that shown .above via:
File > Switch Workspace > Other. This will open the dialog.box.

2 NOTE: you must use our provided workspace directory, as we've supplied starter code-and
other files for some of the labs here.

+ If Eclipse was installed elsewhere, adjust the path to the Eclipse executable accordingly.
+ You can also put a shortcut on your desktop to start Eclipse.
+ If you need to download Eclipse, just do a search for "eclipse packages" and go from there.

— You want the "Eclipse IDE for Java EE Developers."

— Save the zip file to your computer, and then unzip it. The easiest location to unzip it to is C:\,
but another location is fine as long as you can get to it to run the eclipse.exe executable.

Copyright © LearningPatterns Inc. All rights reserved. 8
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Workbench and Java Perspective

Tasks to Perform

¢ Close the Welcome screen and open a Java Perspective

— Click the Perspective icon at the top right of the Workbench and select
Java (see below left)

: — See notes-about perspective icons

¢ Closethe Java EE perspective by right-clicking its icon at the top
right of the' Workbench and selecting Close (see below right)

— The Java EE perspective is the default for the Eclipse Java EE version

O]

, |3 Database Debug
Eﬂ 43 Java EE [ Database Development
## Debug
see notes . GIt

(1 Java |
& Java Browsing
#3Java EE (default)

2! Java Type Hierarchy

\ 4

Lab 1.1 — Getting Started with JUnit 9

Notes:

¢ The Eclipse Java EE version opens in the Java EE perspective by default.

+ In Eclipse Neon/4.6 and later, the perspective switcher does not show the perspective name by
default. To change this, right-click on any perspective icon and Show Text - see examples below.

[T Y
. T, =g

. is: | S g b 5 | 7% javd EE Java

E | T'-E} EE-"'J Close k-

" with labels
T —I—— |
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Customize the Perspective %

1
| Tasks to Perform !
I L) L] [ 1
. ¢ Unclutter the perspective by closing some views !
1
: — Close the Task List and Outline views i
! . - -
. ¢ Open the'Console view: Window > Show View > Console |
1 "
‘e You can save these changes to the perspective [see notes] :
=1k
File  Edit Navigate Search Project Run Window Help
AnR A | FEERAVE" RSN R S Nl an SN ER S S ¢ =
) N 4 _ Quick Access || & ||& Java
[3-Package Explorer 8 [ \i,| 2 ¥ = B8 =g
[, Proﬁeng% 2 console ¥ =8
(0 items
‘ Description | Resource Path | Location |
4 | y _ | j
Lab 1.1 — Getting Started with JUnit 10

Notes:

+ An Eclipse perspective is simply a collection of views, shown as tabbed panes in the Workbench.

— A perspective defines which views are included, where)they are positioned, and what their
relative sizes are in the Workbench.

+ Eclipse has several predefined perspectives, which can be used as-is;.or customized to suit.your
needs / preferences. There's a good chance you'll want to tweak the ones you're using.

— To customize a perspective, open a predefined one, e.g., the Java perspective,‘close the views
you don't want, open any views you do want, reposition and/or resize them; and then save the
changes via Window > Perspective > Save Perspective As.

» TIP: to preserve the factory-shipped perspective and create a brand new perspective’based
on it, use a different name, e.g., "Java [YI]", where "[YI]" are Your Initials in square brackets.

* Window > Perspective > Save Perspective As > Java [YI].

+ Your instructor may also recommend additonal customizations, which s/he will go over with you.
— There are myriad settings, all available via Window > Preferences.
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Create Project and Add JUnit Support %

+ We'll create a new project, presupplied with some starter code

¢ Your tasks include:
— Add JUnit library to project (via JUnit support built in to Eclipse)
— Finish the test cases and run the tests in the IDE

Tasks to Perform £ & sic
. . E-H com.math
+ Create new Java project named exactly Lab01.1 | - cacustorjava
e : (% test
— Must name it this'to pick up starter code > Next E Eﬂi com.math
+ Seemnotes about pre-provisioning the starter code [ CalculatorTest.java

+ In the next dialog (Java Settings), click Libraries tab
— Click Add Library button, select JUnit and then press Next
» Select JUnit 5 (the'default)'and then click Finish
— Back in the main wizard,.click Finish to create the project
— See notes for adding JUnit support after the fact

Lab 1.1 — Getting Started with JUnit 1

Notes:

+ IMPORTANT NOTE: you must name the project Lab01.1, in order to pick up the starter code
we've provided for this lab.

— That's because the starter code was pre-provisioned in'the-workspace/Lab01.1 directory
(in appropriate subdirectories).

— By naming the project Lab01.1, the project directory defaultsto workspace/Lab01.1, and the
starter code is automatically recognized and included in the project’s fileset.

+ After adding the JUnit library to the project, any compile errors you might see’should go away.
See your instructor if they don't, or if you have any problems.

+ If you ever forget to add JUnit during initial project creation, it can easily be added later.
— Right-click on project and choose Build Path > Add Libraries - JUnit > JUnit 5, or
— Build Path > Configure Build Path > Libraries tab > Add Library > JUnit > JUnit 5.

— Also note: you can completely ignore this step, and when you create the first test class in a
project via New > JUnit Test Case, the wizard will prompt you to add JUnit support to the
project (which of course you say "yes" to).

Copyright © LearningPatterns Inc. All rights reserved. 11
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Business Class and Sample Test w

Tasks to Perform
+ Note the structure of the project and the names of the classes
— Parallel src and test directories
— Test classes and business classes in same package

# Review the Calculator class — yes, it's dumb-simple BUT:
—~ Understandiits APl and what to expect from its methods
«_This forms the basis for your test cases
— This'simple class gives us a good example to start with

[# Package Explorer |Ju JUnit &3

¢ Review the CalculatorTest test class

g® &1 BE| @
— Run its test cases (methods) via right-click > Finished after 0.045 seconds
Run As > JUnit Test [see notes] E b ezmm oL s

E---E'E CalculatorTest [Runner: JUnit 5]

...... i testAdd() (0.010 )

— An Eclipse JUnit view appears, with-a green bar

Lab 1.1 — Getting Started with JUnit 12

Notes:

+ You can right-click on the CalculatorTest.java file in-Package Explorer; or just right-click anywhere
in the editor.

Copyright © LearningPatterns Inc. All rights reserved. 12
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Finish the Test Methods w

Tasks to Perform

+ Write additional test methods for the Calculator class, following
the example testAdd () method

- testDivide()

assertkEquals(2.5, calc.divide(5, 2)); // expected, actual

* Run the tests as before: right-click > Run As > JUnit Test

— Stillworking.in testDivide(), try this one:
assertEquals(.571428, calc.divide(4, 7)); // FAIL

» The expected valueis a six-digit repeating decimal — what to do?
assertkEquals(.571428, calc.divide(4, 7), .001); // include a delta

- testIsEven()
* Use assertTrue(),passing in'a should-be-true condition — for example:
assertTrue(calc.isEven(10)); //<also try an assertFalse()
T A e W 11— Geting Stareawin e 13
Notes:

¢ The assertEquals() method is heavily overloaded; with 30 variations. We'll get into the details
after the lab, but what's happening here is that there are‘two versions for comparing doubTles:

— assertEqualsii(double expected, double actual)
— assertEqualsi(double expected, double actual, double delta)
» Asserts that expected and actual are equal within the given delta.

+ Interestingly, JUnit 4 also had these two flavors of floating point assertions,‘but the two-argument
version was deprecated, recommending the delta version as the better alternative.

+ The examples above use method in-lining for the "actual" value in the assertions = this is common,
but of course not required. For example, the testDivide() method could also be written as:

@Test

public void testDivide() {
Calculator calc = new Calculator();
double result = calc.divide(5, 2);
assertEquals(2.5, result);

}

Copyright © LearningPatterns Inc. All rights reserved. 13
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Scoping the Test Run w

+ You can run only one test, all the way up to all tests in a project
— It's simply a function of where you right-click

Tasks to Perform

» Tryitout

— Right-click CalculatorTest.java in Package Explorer
(or anywhere in the editor for it) > all tests in that class

—'Right-click com.math package - all tests in all classes in that package

E — Right-click test source folder -> all tests in all classes in all packages
: in testfolder

i i . @Test
o To run just a single test: S void EISTIETEAG ¢

_ SeleCt the methOd name in the editor System.out.printin("testSortLambda:");
+ Just double-click onit — actually, just a single-click anywhere on it will do

— Then right-click and run test
* You should see only the-results of this single test method

Lab 1.1 — Getting Started with JUnit 14
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Test Setup and Order of Execution w

+ You want a "clean" new instance of Calculator for each test
— This class is stateless (no instance variables), but principle still applies
— We thus instantiate one in each test method [new Calculator()]
. Simple, but the result is redundant setup code in each test method
« “We'll address this later

+ Tests run in isolation, and in no guaranteed order
— Even though you may think you see a pattern

Tasks to Perform B ColcuiatorTest [i

o AN . g testadd() (0.

+ In the JUnit view, note the order of test execution & tism,wfeo',;
— It may appearto-follow the order of methods in test class | % testsEven0

+ Write a new method, testSomething, as the first one in the class
— Rerun all tests > what do you notice? [see notes]

Lab 1.1 — Getting Started with JUnit 15

Notes:

o GOTCHA — there is nothing to notice. Tests should-run in isolation and in no guaranteed order.

— Any pattern you think you see cannot and should not be relied upon. This is a fundamental
principle of unit testing. More info coming.
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JUnit API and Documentation w

Tasks to Perform
¢ Find the supplied JUnit distribution in the lab setup,
in"StudentWork/JavaTesting/Software/junit-5.1.0
— Eclipse-uses its own built-in version
— Maven downloads the JARs from a repository
— Buta standalone distribution is good for API docs, and just to have

referred to as <junit>

+ Open’and bookmark the JUnit Javadoc

— Using a file browser (Windows Explorer), locate the base doc directory
Software/junit-5.1.0/doc
— From here, drill down into docs/current
* Go one level deeper into the api directory and then open index.html
* You should bookmark this start page for the JUnit API doc
* Note also the release-notes and user-guide directories

— Also available online athttp://junit.org/junit5

Lab 1.1 — Getting Started with JUnit 16

Notes:

+ We have found no source for an all-in-one zip for the JUnit 5 Javadocthat can be downloaded and
extracted locally.

— Each module in JUnit 5 is available at Maven Central, and. each provides jar, javadoc.jar, and
sources.jar files. Okay, but there are many modules that we .need to look at.

— We started down this path, downloading the javadoc.jar files for junit-jupiter-api.and
junit-jupiter-params, but quickly realized this was an inferior solution.

— Ultimately, we decided to pull it off junit.org directly, relativizing all the links and.making a few
tweaks. This seems to work perfectly well.

— If you do hit a broken link or something, just start over at the index.html file-that you
bookmarked.
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