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Relationships1.

In this lesson, you will learn...

1. About referential integrity.
2. How to establish relationships between tables.

Review1.1

In the introductory course, we defined a relational database as a collection of data
sets organized in multiple tables. We went on to say that each table in a relational
database has well-defined relationships with one or more other tables in the database.

We showed how to normalize data in preparation for establishing these relationships.
Open Relationships/Demos/Demo - My Music Collection.accdb to begin.

For example, suppose we start with the following unnormalized data:

To achieve First Normal Form, we eliminate repeating groups of data by creating
separate tables for each related group of data and assigning a primary key field to
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each table. In our example, we have no repeating groups, so we simply need to
assign a primary key, Recording_ID, to the Recordings table.

To achieve Second Normal Form, we eliminate redundant data by separating it into
new tables. Notice that in our example, the artist and format data repeats. We need
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to separate these tables from the original Recordings table and assign a primary key
to each table.

Now that the redundant data is separated out,we replace the data in the Recordings
table with foreign keys (the primary keys from the Artists and Recording Formats
tables).

To achieve Third Normal Form, we remove columns in tables that don't depend
directly on the table's primary key. In our relatively simple data set, we don't have
any such columns, so we can consider our data normalized to Third Normal Form.

In brief, each table in a database should have a single focus. When you notice that
secondary items in the table are repeating, it's a signal to break the repeating topic
into a table of its own and assign it its own primary key. This primary key becomes
the source for a foreign key field in the original table. For the sake of good
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organization, though optional, the primary key and foreign key should share the
same name and must be of similar data type.

After normalization, we discussed the three relationships possible between tables.

• One-to-many. Table A has a one-to-many relationship with Table B if a record
in Table A can match one or more records in Table B but each record in Table
B must match only one record in Table A.

• Many-to-many. Table A has a many-to-many relationship with Table B if Table
A can have one or more matches in Table B and Table B can have one or more
matches in Table A.

• One-to-one. Table A has a one-to-one relationship with Table B if Table A can
have no more than one matching record in Table B and Table B can have no
more than one matching record in Table A.

To ensure data integrity it is not enough to simply acknowledge the types of
relationships that exist between tables, it is essential that we define the relationships
so that they can be enforced.
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Referential Integrity1.2

Let's consider the recording tables again. Suppose I delete a record from the Artists
table.

The result is that there are records in the Recordings table that refer to an artist record
that no longer exists. We call this sort of record an orphaned record.

Suppose instead of deleting a record from the Artists table, I change a record:

The result this time is not orphaned records, but incorrect records.
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Referential integrity ensures that orphaned records are not created and that references
are not changed arbitrarily. We can turn on referential integrity when we create
relationships between tables. When referential integrity is turned on, Access refuses
to allow actions that would compromise the integrity of the relationship.

There may be valid reasons for allowing changes to or deletions of primary keys.
For these cases, Access provides Cascade Update Related Fields and Cascade
Delete Related Records options when you enable referential integrity. Cascade
Update Related Fields updates all records that reference the affected primary key.
Cascade Delete Related Records deletes all records that reference the affected
primary key.

Relationships1.3

Access provides a tool for formalizing the relationships among tables. The
relationships themselves are intrinsic to the structure of the database tables. The fact
that we have added a foreign key column to one table with data that matches (or is
compatible with) the data type of the primary key field of another table is sufficient
to establish the relationship. Access, however, provides a tool to formalize this
relationship and help us keep that relationship in mind as we work with the database.

Data Types and Relationships

When you formalize the relationship by connecting a pair of fields in two tables,
you must ensure that the fields have the same data type or compatible data types.
For example, if one field stores its data as numbers and the other stores its data as
text, you cannot use the fields in a relationship.

Significantly, autonumber fields and number fields may be compatible provided
that the field size of the number field is "long integer". For instance, consider the
My Music Collection database. Assuming that the primary key of the Artists table,
Artist_ID, is an autonumber field, we could associate it to the Artist_ID field in the
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Recordings table as a foreign key provided that the Artist_ID in the Recordings table
is a long integer number field. The same would be true for the Format_ID fields.

Formalize the Relationship Between Tables

To formalize the relationship between two tables: Open Relationships/Demos/Demo
- My Music Collection - 3NF.accdb to begin.

1. Open the database. (For this demonstration, we'll use the Demo - My Music
Collection - 3NF database.)

Page 7 of 329Version: 1.0.1. Printed: 2016-04-05.

Relationships

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



2. On the Database Tools tab, click Relationships.

3. The Show Table dialog box opens.

4. On the Tables tab, highlight the tables you want to establish relationships
between, then click Add.
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5. Click Close. Representations of the tables are added to the Relationships tab
in the workspace.

6. To establish a one-to-many relationship, highlight the key field from the "one"
side of the relationship and drag and drop it onto the corresponding field in the
table on the "many" side of the relationship.

The Edit Relationships dialog box opens.
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7. Mark the Enforce Referential Integrity check box. We'll leave the Cascade
Update Related Fields and Cascade Delete Related Records check boxes
cleared.

8. Click Create. A connector is added between the tables.

9. Repeat steps 5-7 to relate the Format_ID field in the Recording Formats table
to the Format_ID field in the Recordings table.
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10. Click Save.

A Few Words about Naming Conventions1.4

In this course we will not impose a structure on the names of our database objects.
This will make it more natural to refer to database objects in context. However, for
larger or more complex databases you will want to consider using a naming
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convention to help you distinguish among objects. Using a naming convention is
particularly helpful if other people may maintain your application.

A commonly used convention for Access databases is the Leszynski/Reddick naming
convention. Briefly, this convention adds a tag in lower case letters before the object
name and omits all spaces.

ExampleTagObject Type

tblRecordingstblTable

tlkpFormatstlkpTable Lookup

qryCDRecordingsqryQuery

qappRecordingsAction Query • qapp (append)
• qxtb

(crosstab)
• qdel (delete)
• qmak (make

table)
• qry or qsel

(select)
• qupd (update)

frmRecordingEntryfrmForm

sfrmCompilationssfrmSubform

rptMusicListrptReport

srptCompilationssrptSubreport

mcrAddRecordingsmcrMacro

cmdOpenRecordingsFormcmdCommand

A variant of the Leszynski/Reddick convention includes an underscore between the
tag name and the object name: tbl_Recordings.

A similar naming convention has the advantage of making it easy to distinguish
among object types like the Leszynski/Reddick convention does, but has the added
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benefit of being easier to search. By this convention we append a tag in upper case
letters to the end of the object name while omitting all spaces.

ExampleTagObject Type

RecordingsTBLTBLTable

FormatsLKUPLKUPTable Lookup

CDRecordingsQRYQRYQuery

APPEND_RecordingsQRYAction Query • APPEND_ObjectNameQRY
• XTAB_ObjectNameQRY
• DELETE_ObjectNameQRY
• MAKE_ObjectNameQRY
• SELECT_ObjectNameQRY
• UPDATE_ObjectNameQRY

RecordingEntryFRMFRMForm

CompilationsSFRMSFRMSubform

MusicListRPTRPTReport

CompilationsSRPTSRPTSubreport

AddRecordingsMCRMCRMacro

OpenRecordingsCMDCMDCommand

Whichever convention you choose, it is important to use it consistently across your
application.

Page 13 of 329Version: 1.0.1. Printed: 2016-04-05.

Relationships

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



Creating RelationshipsExercise 1
15 to 45 minutes

In this exercise, you will add an Accounts table to the Bank Register database, add
a field for the foreign key to the Transactions table, and formalize the relationship
between the Accounts table and the Transactions table. Open Relationships/Exercis
es/Bank Register.accdb to begin.

The Accounts table will store the following information:

AccountNameAccountNumberRoutingNumberAccount_ID

Checking0064003156781125007491

Savings0064002678911125007492

All the transactions entered thus far in the database are for the checking account.
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Exercise Solution

To add the table to the database:

1. Open the database.
2. On the Create tab in the Tables group, click Table Design. A new table opens in Design

view.
3. In the Field Name column in the first row, type "Account_ID".
4. In the Data Type column, select "AutoNumber".
5. In the Description field, type "Record number automatically assigned by Access."
6. In the Field Properties area on the General tab, in the Caption field, type "Account_ID".
7. From the Indexed drop-down list, select "Yes (No Duplicates)".
8. In the next row of the field definition area, enter the following information for the Routing

Number field:

Field Name: RoutingNumber

Data Type: Short Text

Description: Enter the routing number for the bank.

9. In the Field Properties area on the General tab, enter values for the following properties:

Field Size: 9

Caption: Routing Number

Required: Yes

Indexed: Yes (Duplicates OK)

10. In the next row of the field definition area, enter the following information for the Account
Number field:

Field Name: AccountNumber

Data Type: Short Text

Description: Enter the bank account number.

11. In the Field Properties area on the General tab, enter values for the following properties:

Field Size: 12

Caption: Account Number

Required: Yes

Indexed: Yes (Duplicates OK)

12. In the next row of the field definition area, enter the following information for the Account
Name field:
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Field Name: AccountName

Data Type: Short Text

Description: Enter a name for the bank account.

13. In the Field Properties area on the General tab, enter values for the following properties:

Field Size: 40

Caption: Account Name

14. In the field definition area, highlight the Account_ID row.
15. On the Table Tools: Design tab in the Tools group, click Primary Key.

16. Click Save. The Save As dialog box opens.
17. In the Table Name field, type "Accounts".

18. Click OK.
19. Switch to Datasheet view and add the records specified above.
20. When you finish, close the table.

To add a foreign key field to the Transactions table:
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1. Open the Transactions table in Design view.
2. In the field definition area, highlight the Code row and on the Table Tools: Design tab in the

Tools group, click Insert Rows.

3. In the row you just inserted in the Field Name field, type "Account_ID".
4. In the Data Type field, select "Number".
5. In the Description field, type "Foreign key to Accounts table."
6. In the Field Properties area on the General tab, enter a value for the following property:

Caption: Account ID

7. Click Save.

8. Switch to Datasheet view.
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9. In the Account_ID column, fill in each row with "1".

10. Switch to Design view.
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11. With the Account_ID row selected in the field definition area, go to the Field Properties area
on the General tab and change the Required value to "Yes".

12. Click Save. You are prompted about data integrity issues.

13. Click Yes.
14. Close the Transactions table.

To formalize the relationship between the Accounts table and the Transactions table:
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1. On the Database Tools tab, click Relationships. The Show Table dialog box opens.

2. On the Tables tab, highlight the Accounts and Transactions tables, then click Add.

3. Click Close. Representations of the tables are added to the Relationships tab in the workspace.

4. Highlight the Account_ID field in the Accounts table and drag and drop it onto the Account_ID
field in the Transactions table.
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The Edit Relationships dialog box opens.

5. Mark the Enforce Referential Integrity check box. Also mark the Cascade Update Related
fields and the Cascade Delete Related Records check boxes.
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6. Click Create. A connector is added between the tables.

7. Click Save.
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Conclusion1.5
In this lesson, you learned:

• About referential integrity.
• How to establish relationships between tables.
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Reports5.

In this lesson, you will learn...

1. To create reports in Design view.
2. About the sections of a report.
3. To add fields to a report.
4. To move, resize, and format the objects on a report.
5. To manipulate the page header/footer, the report header/footer, and group

headers/footers on a report.
6. To group and sort records on a report.
7. To work with report, section, and object property sheets.
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Design View5.1

Many of the techniques we learned in the forms lesson will apply as we learn to
design reports. In particular, the methods for moving, resizing, and formatting objects
are identical.

As with forms, Design view gives you the maximum control over the aesthetics and
performance of your reports. Files are located Reports_Advanced/Demos/Demo -
My Music Collection - Start.accdb.

To start a report in Design view, go to the Create tab in the Reports group and click
Report Design. A blank design tab opens on the work surface.

Name and save the form. (We'll name the report "Music List".)

Next, we need to give our report a record source. To do this we'll use the "Record
Details" query that we created in the forms lesson.

1. To associate the query with the report, right-click in the design surface and
select Report Properties from the shortcut menu.
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2. From the Record Source drop-down list, select "Recording Details".

3. Close the property sheet.

Note: You may make a copy of a report that you have made, assuming you like the
layout and formatting and then change the source as a shortcut way to reuse existing
reports. If you have different field names, those will need to be added, modified, or
deleted in the report to match the new source.

Report Sections5.2

Reports have three standard sections: page header, detail, and page footer. In addition,
you can add group header/footer and report header/footer sections.

Report Header

If you include the optional report header section, it is visible on the first page of the
report only. You can use it for report information that only needs to appear once on
the report such as a logo, title, and date. The report header and footer are paired, so
when you add one to the form, you add them both.
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Page Header

The page header section appears at the top of each page of the report. For a tabular
report, the page header is a good place for column headings.

Group Header

If you group the data in your report, Access adds a group header section that is
visible before each new grouping on the report. You can use it to print the group
name for each grouping on the report. There can be multiple group headers on the
report depending on how many grouping levels you include.

Detail

The detail section contains one record for each row in the record set. This is the
main section of the report.

Group Footer

If you include group totals on a report, the group footer section appears at the end
of each grouping on the report. The group footer typically shows summary
information for each group. There can be multiple group footers on a report
depending on how many grouping levels you include.

Page Footer

The page footer appears at the bottom of each page of a report. The page footer
usually contains page numbers.

Report Footer

If you include the optional report footer section, it appears once at the end of the
report. The report footer contains summary information for the entire report. For
example, the report footer might be used to show report grand totals.

Adding a Report Header/Footer

To add report header/footer sections to a report:
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1. Display the report in Design view.
2. Right-click on the design surface and select Report Header/Footer from the

shortcut menu.

The report header and footer are added to the design surface.

Adding a Logo to the Report Header

To add a logo to the report header:
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1. Resize the header section as needed to accommodate the logo.

2. On the Report Design Tools: Design tab in the Header/Footer group, click
Logo.

3. Navigate to and select the logo file.

4. Click OK. The logo is added to the report header area.
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5. Move and resize the logo as needed.

6. Switch to Print Preview to preview the logo.

7. When you finish, click Close Print Preview.

Adding a Title to the Report Header

To add a title to the report header:
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1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Title.

2. Type the title for the report.

3. Go to the Report Design Tools: Format tab and make any formatting changes
you want.

4. Return to the Report Deesign Tools: Design tab, then switch to Print Preview
to preview the report.
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5. When you finish previewing the report, click Close Print Preview.

Adding Fields to a Report

Next, we'll add some content to the report by adding fields to the design surface.

To add fields to the report:
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1. On the Report Design Tools: Design tab in the Tools group, click Add
Existing Fields.

2. In the Field List pane, double-click the field names you need to add them to
the design surface.

Add Calculated Fields

When the data you need is not directly available in the field list, then you must create
a calculated field (formula) to display the data wanted.
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1.

Design > Controls > Text Box
2.

Enter the formula into the Data Tab > Control Source area.
3.

Page 211 of 329Version: 1.0.1. Printed: 2016-04-05.

Reports

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



The finished report may look similar.

Arranging Fields on a Report5.3

As with forms, Access adds the fields in the order you selected them and stacks
them. For this report, we want a tabular layout, so we'll adjust the layout accordingly.

The same techniques for moving and resizing fields on a form apply to reports. This
time, however, we're going to stack the labels on top of their corresponding fields.
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If needed, remember to use the Report Design Tools: Arrange tab to apply
alignment and spacing to the report objects.

Use the Report Design Tools: Format tab to apply formatting to the report objects.

Preview your work as necessary to ensure you are achieving the results you want.

Resizing the Detail Section5.4

When you previewed the report, you may have noticed that the report is displaying
one record per page. The Detail section needs to be only as tall as the height of one
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record plus any spacing you want to allow between records. For this reason, we need
to resize the height of the Detail section.

When we preview the report now, we see that there are multiple records per page.

To create multiple columns in a report, you may choose Page Setup > Page Layout
> Columns. Choose the proper settings, and click OK.
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Eliminating Repeating Headings

You may have noticed that the labels in our example repeat for every record. That's
because the labels are included in the Detail section of the report.

We can move the labels to the Page Header if we want them to print just once at the
top of every page of detail.

To do so:

1. In Design view, select all the labels.

2. Press Delete.
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3. Move the fields up and resize the Detail section to account for the extra space
caused by deleting the labels.

4.
On the Report Design Tools: Design tab in the Controls group, click .

The cursor changes to .
5. In the Page Header, click and drag a rectangle above the first field to create a

label.
6. In the label, type the text you want to appear above the corresponding detail

column.
7. Repeat steps 4-6 for each of the labels you need to add.

8. After you add the labels you need, tweak the sizing and placement as needed.

Tip: You can move selected objects by small increments by pressing Ctrl and
the arrow on your keyboard that corresponds to the direction you want to move.
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Tip:You can resize selected objects by small increments by pressing Shift and
the arrow on your keyboard that corresponds to the direction in which you want
to resize.

Tip:You can use the Size/Space options on the REPORT DESIGN TOOLS:
ARRANGE tab to quickly equalize the size of several objects. For instance,
if you want to make all the labels the same height as the shortest label, you
would select Size/Space > To Shortest from the menu.
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9. Perform any formatting changes you want to make to the labels.
10. When you finish, preview your results.

Set Margins

Margins will affect the amount of information that will be displayed in the printed
page. Page Setup > Page Size > Margins.

Grouping and Sorting5.5

You can control how the information on the report is grouped and how data within
those groups is sorted.

First, you can sort without grouping. To do so:
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1. On the Report Design Tools: Design tab in the Grouping & Totals group,
click Group & Sort. The Group, Sort, and Total pane appears at the bottom
of the window.

2. Click Add a sort. A list of fields you can sort by displays.

3. Select a field to sort by.

4. Preview the report. Notice that the report is sorted alphabetically by the column
you selected.
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To group and sort the report:

1. In Design view, clear the sorting you just applied by clicking  at the end of
the Sort by line in the Group, Sort, and Total pane.

2. Click Add a group.
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3. From the drop-down list, select the field to group by.

4. Preview the report. Notice how the report is grouped.

5. Back in Design view, notice that Access has added a group header section
(called "Format Header" in our example). This is causing gaps between the
groupings in the report. If we don't want to include a group heading, we can
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resize the group header so that it doesn't take up any space. However, let's add
a label that shows the group name instead.

6.
On the Report Design Tools: Design tab in the Controls group, click .

The cursor changes to .
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7. Click and drag a rectangle in the group header section. This is the text box we
will use to add the group names.

8. The text box has a label with it that we will not need. Click on the left side of
the text box to select it. (It may be a bit difficult to find.)

9. Press Delete.
10. Notice that the text box is labeled "Unbound". This means there is no data tied

to the text box at this time. For our example, we want to bind the text box to
the Format Description field.

11. Right-click on the text box and select Properties from the shortcut menu. The
property sheet for the text box opens.
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12. On the Data tab, from the Control Source drop-down list, select the field to
bind to the text box.

13. Close the property sheet.
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14. Preview the report. Notice that each group now starts with a group name.

15. Format the text box and resize the group header section to achieve the look
you desire.

16. Now, to sort the data within each group, go to the Group, Sort, and Total
pane and click Add a sort.
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17. From the drop-down list, select the field to sort by.

18. If you want to sort by a second field, click Add a sort again and select another
field.

19. Preview your report. Notice the grouping and sorting.
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Setting Properties on a Report5.6

As with forms, we've hardly made a dent in the number of items that can be managed
on a report. To see all the available properties, we can refer to the property sheets
for the report, the report sections, and the individual objects on the report.

The property sheets for reports are laid out the same as those for forms.
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Report Property Sheet

To view the property sheet for the report, right-click anywhere in the report design
surface and select Report Properties from the shortcut menu.

Section Property Sheet

To view the property sheet for a particular section of a report, right-click in that
section and select Properties from the shortcut menu.
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Object Property Sheet

To view the property sheet for any object on the report, right-click the object and
select Properties from the shortcut menu.
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One property that you may find useful on reports is the Can Grow property. When
applied to a text object that represents a field with values of variable length, Can

© Copyright 2016 Webucator. All rights reserved.Page 230 of 329

Reports

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



Grow expands the vertical space that a value displays in if it would otherwise be
cut off.

To demonstrate the Can Grow property, we'll temporarily shorten the Title field
object.

To apply the Can Grow property:

1. In Design view, select the field object you want to apply the Can Grow property
to.

2. If it's not currently showing, open the property sheet for the field object.
3. Select the Format tab.
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4. If necessary, scroll down to find the Can Grow field and select "Yes" from
the drop-down list.

5. Preview the report.

A helpful characteristic of property sheets is the ability to select multiple objects
and then to view and change the properties that the objects have in common.

To demonstrate how to use the multiple selection property sheets, let's remove the
borders around the data on the report.

To do so:
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1. In Design view, select the objects you want to remove the borders from.

2. On the Report Design Tools: Design tab in the Tools group, click Property
Sheet.

3. Select the Format tab.
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4. From the Border Style drop-down list, select "Transparent".

5. Preview your report.

While we're at it, let's remove the shading too.

The shading in our example occurs in two places, the group header section and the
detail section.

To remove the shading:
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1. Select the group header and open its property sheet.
2. Select the Format tab.
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3. From the Alternate Back Color drop-down list, select "No Color".

4. Repeat this procedure for the Detail section.
5. When you finish, preview the report.

Adding Record Counts

Access can show us the number of records in a group and the total number of records
on our report. To accomplish this, we use the Totals feature.
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To show record counts on the report:

1. In Design view, on the Report Design Tools: Design tab in the Grouping &
Totals group, click Group & Sort to open the Group, Sort, and Total pane.

2. In the Group on line, click More.

3. Click the with no totals drop-down list.

4. From the Type drop-down list, select "Count Records".
5. Mark the Show Grand Total check box.
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6. Mark the Show subtotal in group footer check box.

Notice that a group footer is added to the report design and that Count fields
have been added in the group footer and report footer.

7. Preview the report.
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We have totals now, but they look a little stark without labels to identify them. We'll
go ahead and add labels and tweak the formatting.

To add labels to the Count fields:

1. Right-click on the Count field and select Set Caption from the shortcut menu.
2. Resize the label as needed.
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3. Change the label text to describe the totals.

4. Preview the report.

Suppose we want to customize our group total labels to indicate what is in each
group. We can do that using a text box and a simple expression.

To customize the group label:
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1. Select the label in the group footer, right-click, and select Change To > Text
Box from the shortcut menu.

2. In the ribbon, click Property Sheet.
3. In the property sheet, select the Data tab.
4. From the Control Source drop-down list, select the field with the values you

want to build the label around.
5. Move the cursor in front of the field name in the Control Source field and type

"=", then in quotes type any text you want to precede the field name. If you
need to include a space after, you can enclose that in the same quotes.
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6. Type a "+".

7. Move the cursor after the field name, type "+" and then type any text you need
to follow the field name. Put quotes around the text you type and include spaces
inside the quotes as needed.

We have created a simple expression that concatenates (combines) text and a
field to make a custom label.
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8. Preview your report.

9. Notice that the new labels are enclosed in those pesky borders, so clean those
up if desired and make any other tweaks you want to the formatting.

Special Report Fields5.7

Access includes a couple of built-in report fields for standard report formatting:
dates and page numbering.

Dates

To insert a date in your report to indicate when the report was produced:
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1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Date and Time. The Date and Time dialog box opens.

2. Select the date style you want, decide if you want to include the time and, if
so, the style you want, and click OK. The date field is inserted in the header
of your report.

3. Move, resize, and format the date field and other fields as desired.
4. Preview your report.
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Page Numbering

To insert page numbers in the page header or footer of your report:
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1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Page Numbers. The Page Numbers dialog box opens.

2. Select the format, position, and alignment of page numbers for your report. If
you don't want to see the page number on the first page of the report, clear the
Show Number on First Page check box.

3. Click OK. The page number is inserted into the page at the position you
selected.

© Copyright 2016 Webucator. All rights reserved.Page 246 of 329

Reports

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



4. Preview the report.

5. Move, resize, and format the page number as desired.
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Controls5.8

The controls available on a report are the same as those available for forms minus
the Web Browser Control and the Navigation Control.

We'll demonstrate using a couple of these controls in our report. First, we'll add a
line to improve the layout of our report, then we'll insert a page break.

Let's add a line below the group header to set off each of the groups in the report.

To add a line:

1. In Design view, enlarge the group header section a bit.
2. On the Report Design Tools: Design tab in the Controls group, open the

drop-down list and click . The cursor changes to .
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3. Click and drag a line below the group label from near the left edge of the report
to near the right edge. You can press Shift while you're drawing the line to
ensure that it is straight.

4. Preview the report.

5. Tweak the size of the group header and the position of the group header label
to achieve the desired effect.

Suppose we want the report to start a new page each time a new group section starts.
To do that, we can insert a page break in the group footer.
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To insert a page break:

1. In Design view, on the Report Design Tools: Design tab in the Controls

group, click . The icon changes to .
2. Click in the group footer below the Count field. A page break marker is added

on the left.

3. Preview the report.

Due to the short length of our report, we'll remove the page breaks for now. To do
so, return to Design view, highlight the page break marker, and press Delete.
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Printing a Report

After we've got our report with the information we want on it, in the format we want,
we can print it. To prepare for printing, we need to ensure that the printable page is
set up to our satisfaction.
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Setting Page Layout

To access page setup options, go to the Report Design Tools: Page Setup tab.

The ribbon presents most of the page setup options individually, but if we click Page
Setup, we'll find all the options collected in one place.

Margins may be altered to suite your needs.

You can also choose Page Orientation and general paper size. These settings remain
with the report.
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Since these settings should be familiar to you, we'll not discuss them at length here.

After you have the page set up as desired, preview the report in Print Preview mode,
then on the Print Preview tab, click Print.

Notice on the Print Preview tab that you can also output your report to a variety of
other formats including .xls, .txt, .pdf, .xps, .rtf, .html, and e-mail.

Subreports5.9

Many times it would be helpful to show a table of data that is either related to or
not related to the main report. Files are located Reports_Advanced/Demos/Demo -
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My Music Collection - Grouping and Sorting.accdb. We may use a subreport to
achieve this. Design > Controls > Controls > Subform/Subreport.

Draw the report object in the proper section. For example, if we want the subreport
at the bottom of each page, use the Page Footer area.

A wizard should present itself, assuming they are activated, to lead you through the
remaining choices. Choose to use an existing object. Click Next.
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Choose the fields from the source you wish to show. Keep in mind if it will be
related, you should be aware of your table relationships such as the Primary and
Foreign keys which connect the data. Click Next.

Choose a connection, if you want to show all of the data, then choose None. Click
OK.
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Name your subreport. Click OK.

Your report may look like this.
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Application Parts5.10

Creation of reports may be started by using any existing reports in the Application
Parts. Many of the reports are bundled with other objects such as tables to store the

Page 257 of 329Version: 1.0.1. Printed: 2016-04-05.

Reports

EVALUATION COPY 

 
 

Unauthorized Reproduction or Distribution Prohibited



data, and forms to enter the data. These may be customized and changed as needed
once they are created.

Deleting a Report5.11

When a report is no longer needed, you may delete it by right mouse clicking on a
report name and choosing Delete.
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Formatting a Report5.12

Using the Ribbon, or the Property Sheet, most aspects of the report can be altered.
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Adding a Background and Images and Applying a Theme

Themes allow an efficient way to develop a consistent color through out the report.

1. Click on Design > Themes > Colors.
2. Choose a theme that you wish to use. Click on it to apply.
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Images create an easy way to brand a set of reports to a corporate identity.
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1. Click on Format > Background > Background Image > Browse.

2. Choose the proper picture. Click OK.

3. The picture is now placed behind the report objects as a background.
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Creating ReportsExercise 7
25 to 45 minutes

In this exercise, you will create a report of transactions from the Bank Register
database. Use the database found in the ClassFiles/Reports_Advanced/Exercises
folder as a starting point.

1. Create a query based on the Transactions table that shows uncleared checking
account transactions. Name the query "Uncleared Checking Transactions".

2. Create a tabular report based on the Uncleared Checking Transactions query.
The report should have the following characteristics:
A. Add the following title to the report: "Uncleared Bank Transactions". Add

a date field in the report header.
B. Show the following fields: TransDate, Code, Description, and Amount.
C. Group the records on the report by credits and debits and sort them first

by date, then by description.
D. Label the credits group "Credits" and the debits group "Debits". (This will

require you to build an expression. Hint: Research the "IIf" function.) Put
a line under the group labels.

E. Show a subtotal for each group. Label the subtotals "Total Credits" and
"Total Debits".

F. Show a report total. Label the total "Grand Total". Add a line above the
label.

G. Add page numbers at the bottom right.
H. Tweak the formatting as you like.
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Exercise Solution

To create the query:

1. On the Create tab in the Queries group, click Query Design.
2. In the Show Table dialog box, select "Transactions" and click Add.
3. Click Close.

4. In the Transactions table, double-click to add the Account_ID, TransDate, Code, Description,
Amount, Credit, and Cleared fields to the query design grid.
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5. In the Account_ID column in the Criteria row, type "1". (The checking account's record ID
is "1".)

6. In the Cleared column in the Criteria row, type "False".

7. Run the query.

8. Save the query as "Uncleared Checking Transactions".
9. Close the query.

To create the report:
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1. On the Create tab in the Reports group, click Blank Report.
2. Switch to Design view.
3. Right-click in the design surface and select Report Properties.
4. Select the Data tab.
5. From the Record Source drop-down list, select the Uncleared Checking Transactions query.

6. Close the property sheet.
7. On the Report Design Tools: Design tab in the Header/Footer group, click Title.
8. Type the title for the report: "Uncleared Bank Transactions".
9. In the Header/Footer group, click Date and Time.
10. In the Date and Time dialog box, select options for the date and time, then click OK.
11. Format the title and date as desired.

12. On the Report Design Tools: Design tab in the Tools group, click Add Existing Fields.
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13. In the Field List pane, in the Transactions list, double-click "TransDate", "Code", "Description",
and "Amount".
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14. Select all the field labels and press Delete.

15. Arrange the fields across the top of the detail section. Resize the fields relative to the data that
each contains.

16. Reduce the height of the detail section.

17. Add labels for each of the fields in the Page Header section using the label control.
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18. Resize, align, and format the labels.

19. While we're tweaking the formatting, remove the field borders and the alternate row shading.
To do so:
A. Select the labels in the page header and the fields in the detail section.
B. Open the property sheet.
C. Select the Format tab.
D. From the Border Style drop-down list, select "Transparent".
E. Click in the Credit Header section.
F. In the property sheet, on the Format tab, from the Alternate Back Color drop-down

list, select "No Color".
G. Click in the Detail section (but not on a field object).
H. From the Alternate Back Color drop-down list, select "No Color".
I. Close the property sheet.

20. On the Report Design Tools: Design tab in the Grouping & Totals group, click Group &
Sort.

21. In the Group, Sort, and Total pane, click Add a group.
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22. From the select field drop-down list, select "Credit".

23. Click Add a sort and select "TransDate" from the drop-down list.

24. Click Add a sort again and select "Description".

25. In the Credit Header section, add a text box to show the group header label.
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26. Delete the label from the text box you just added.

27. Select the text box, open the property sheet, and select the Data tab.
28. On the Control Source field, click . The Expression Builder opens.
29. In the Expression Elements list box, expand the Functions list and select Built-In Functions.
30. In the Expression Categories list box, select "Program Flow".
31. In the Expression Values list box, double-click "IIf". The expression you've built displays in

the expression window.

32. Replace the <<expression>> placeholder with "[Credit]=True".
33. Replace the <<truepart>> placeholder with "Credits" (enclosed in quotes).
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34. Replace the <<falsepart>> placeholder with "Debits" (enclosed in quotes).

35. Click OK.
36. In the property sheet, remove the borders from the label by selecting "Transparent" from the

Border Style drop-down list.
37. Format the group header label as desired.

38. Close the property sheet.
39. Enlarge the Credit Header to make room to add a line below the label.
40.

On the Report Design Tools: Design tab in the Controls group, click .
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41. Click and drag to draw a line from near the left edge of the Credit Header to near the right
edge of the Credit Header.

42. In the Group, Sort, and Total pane in the Group on row, click More.
43. From the with no totals drop-down list, select "Totals".
44. From the Total On drop-down list, select "Amount".
45. From the Type drop-down list, select "Sum".
46. Mark the Show Grand Total check box.
47. Mark the Show subtotal in group footer check box.

48. In the Credit Header, select the label, right-click, and select Copy.
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49. In the Credit Footer, right-click and select Paste.
50. Open the property sheet for the Credit Footer label and select the Data tab.
51. In the Control Source field, place your cursor immediately after the "=" sign and type "Total

" followed by "+".

52. Move and format the label as desired.
53. Remove the alternate formatting on the group footer.
54. In the Report Footer, add a label for the report totals.
55. In the label, type "Grand Total".
56. Above the label, add a line from near the left edge to near the right edge.

57. On the Report Design Tools: Design tab in the Header/Footer group, click Page Numbers.
58. In the Page Numbers dialog box, in the Format field, select "Page N".
59. In the Position field, select "Bottom of Page [Footer]".
60. In the Alignment field, select "Right".
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61. Mark or clear the Show Number on First Page check box as you prefer.

62. Click OK.
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63. Format the page number as desired.

64. Preview the report.

65. Notice that the grand total is incorrect. That's because we treated credits and debits both as
positive numbers and simply added them up. To fix this, first select the total field in the report
footer.

66. Open the property sheet and select the Data tab.
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67. In the Control Source field, click .

68. In the expression pane, we need to replace the expression with an expression that will add the
credits and add the negative of the debits. To do this, type
"=Sum(IIf([Credit]=True,[Amount],-[Amount]))".

69. Click OK.
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70. Preview the report.

71. Tweak the report as desired.
72. Save the report and name it "Uncleared Bank Transactions".
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Conclusion5.13
In this lesson, you learned:

• To create and format Access reports.
• To work with the various sections of a report.
• To group, sort, and add totals for records on a report.
• To work with the Expression Builder.
• To work with property sheets.
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